Pre-order Stronghold Crusader 2 now!

  Stronghold Crusader 2 is available to pre-order! Order now for bonuses including 2 mini-campaigns, 10% discount & more!
 
New Stronghold HD & Crusader HD Patches Now Available
Friday, 16 November 2012
SHC HD

We have added new HD patches for Stronghold, Stronghold Crusader and Stronghold Crusader Extreme to their official websites, fixing bugs and installer issues reported by players.

The new HD patch for Stronghold solves a number of problems reported by players, allowing the patch to be installed even if it cannot automatically detect the game. It also fixes a crash when selecting troops in the Map Editor and an overlapping worker text bug in the information panels.

The new HD patches for Stronghold Crusader and Stronghold Crusader Extreme allows the patch to be installed even if it cannot automatically detect the game. Click Read More for a list of links and fixes.

 

This updated patch contains the following fixes:

  • If the patch fails to auto-detect the original install, it will give players the option to install the patch manually
  • Fixed crash in Stronghold Map Editor
  • Fixed small text issue (bug from 2001!)

Stronghold

Stronghold Crusader

Stronghold Crusader Extreme

STEAM: Unfortunately, these patches will not work with the Steam versions. We're currently in talks with Steam about adding the HD versions and updating the Stronghold Collection versions of the games. We just need to wait for Steam to give us the green light and we will be sure to let you all know when they do.

HD Patch Information

We have noticed some posts from people experiencing issues with the HD Patches.

Currently the HD patches only support the following languages: English, French, German, Italian and Spanish. We are looking into supporting more languages in the future.

The HD patches do not support the Steam versions of our games; we are in talks with Valve about this at the moment and hope to have Steam versions available soon.

Players with the Stronghold Collection (non-Steam) only need to run the Stronghold HD and Stronghold Crusader Extreme HD patches. The Stronghold Crusader Extreme HD Patch updates Crusader automatically.

For customers who have seen the ‘Error Mode Not Support’ message after patching. Please email us at the address shown below.

There are three patches available at the moment.

Patch Old Versions Patched Version Incompatible
Stronghold HD Stronghold 1.0, 1.1, 1.2 Stronghold HD 1.3 None
Stronghold Crusader HD Stronghold Crusader 1.0, 1.1 Stronghold Crusader HD 1.3 Stronghold Crusader Extreme, Stronghold Collection
Stronghold Crusader Extreme HD Stronghold Crusader Extreme 1.2.1 Stronghold Crusader Extreme HD 1.3.1 Stronghold Crusader 1.0, 1.1, Warchest Edition.

Many versions of Stronghold and Stronghold Crusader have been released over the years and we have tried to test as many versions as possible. If you are having problems upgrading your copy of Stronghold or Stronghold Crusader please email This e-mail address is being protected from spam bots, you need JavaScript enabled to view it with the following information:

Game: e.g. Stronghold
Version: e.g. Stronghold Warchest
Language: e.g. English
Description of the problem: e.g. The patch says i do not have Stronghold installed.
Error Message: e.g. The setup has detected that version 1.30.1000 of Stronghold Crusader HD is already installed.

 

 
< Prev   Next >

Search

Login

 
     Lost Password?
Login for exclusive content, forums, & more!

Contact Us

For a quick answer you can tweet your question to @fireflyworlds anytime from 10am-6pm GMT, Monday to Friday.

© 2014 Firefly Studios - Terms of Use - Privacy Policy
Firefly RSS News Feed
Joomla! is Free Software released under the GNU/GPL License.
Firefly Studios @ YouTube Firefly Studios @ Twitter Firefly Studios @ Facebook